Arofanatics Fish Talk Forums  

Go Back   Arofanatics Fish Talk Forums > Arowana Forum > Arowana Discussion

Reply
 
Thread Tools Display Modes
Old 30-10-2015, 09:46 AM   #1
chubbyaro
Arofanatic
 
Join Date: Jun 2012
Posts: 302
Default persistent fungus

Hi all

My aro has fungus on the head from jumping and scratching its head. I have tried arowana o disease, pimafix melafix and yellow powder but all dont seem to work.. anything else i can do to kill the fungus? Thanks
chubbyaro is offline   Reply With Quote
Old 30-10-2015, 10:44 AM   #2
dm484705
Arofanatic
 
dm484705's Avatar
 
Join Date: May 2015
Posts: 91
Default

Might need to look at the root cause of the problem... My Aro had lice from feeder fish and kept rubbing it body and scratching it's body on the filter... Could not see the lice then till it got bigger... Tried all... Pirma & Melanin before then when I could see the lice it was only then I was able to do the right treatment and got rid of the lice... With fungus you must also keep good water conditions to aid the recovery of the fish.

Hope this helps...



Sent from my iPhone using Tapatalk
dm484705 is offline   Reply With Quote
Old 30-10-2015, 11:00 AM   #3
streetsmart73

Hi there !!! 123
 
streetsmart73's Avatar
 
Join Date: Dec 2010
Posts: 3,895
Default

Ts, shall appreciate it if you can download a clip of your aro
streetsmart73 is offline   Reply With Quote
Old 30-10-2015, 11:56 AM   #4
chubbyaro
Arofanatic
 
Join Date: Jun 2012
Posts: 302
Default

Hi pls see video

http://s289.photobucket.com/user/joh...m28va.mp4.html
chubbyaro is offline   Reply With Quote
Old 30-10-2015, 01:35 PM   #5
matthew
Senior Dragon
 
matthew's Avatar
 
Join Date: May 2007
Posts: 3,023
Default

dun look like fungus at all. more like scratch/bump marks to the top scale.
matthew is offline   Reply With Quote
Old 30-10-2015, 02:51 PM   #6
chubbyaro
Arofanatic
 
Join Date: Jun 2012
Posts: 302
Default

Quote:
Originally Posted by matthew View Post
dun look like fungus at all. more like scratch/bump marks to the top scale.
Its spreading started from head now upto 2nd scale and also see some spider webs like things on the scale
chubbyaro is offline   Reply With Quote
Old 30-10-2015, 03:52 PM   #7
Squid
Endangered Dragon
 
Squid's Avatar
 
Join Date: May 2001
Posts: 8,035
Default

hi Chubby,

Have you tested your water parameters to make sure there's nothing wrong with parameters that might be annoying your aro?

thanks
Squid is offline   Reply With Quote
Old 30-10-2015, 04:22 PM   #8
chubbyaro
Arofanatic
 
Join Date: Jun 2012
Posts: 302
Default

Quote:
Originally Posted by Squid View Post
hi Chubby,

Have you tested your water parameters to make sure there's nothing wrong with parameters that might be annoying your aro?

thanks
Yup water parameters are fine
chubbyaro is offline   Reply With Quote
Old 30-10-2015, 04:27 PM   #9
Squid
Endangered Dragon
 
Squid's Avatar
 
Join Date: May 2001
Posts: 8,035
Default

have you also tried cleaning the filters?
it might be time to change your filter media.

try Salt. bring concentration up to 0.6% slowly. and then maintain for a few weeks.
Squid is offline   Reply With Quote
Old 30-10-2015, 04:30 PM   #10
Squid
Endangered Dragon
 
Squid's Avatar
 
Join Date: May 2001
Posts: 8,035
Default

looking at the video , it doesnt look like fungus, but scratch to the head.
Squid is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +9. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Copyright 2000-2008 Arofanatics.com (Since 30th August 2000)